Pinnacle - Hitting the highest Point
DISCLAIMER :
This website [Pinnacle.withme.us] claims no credit for any information, news and/or images featured on this site unless otherwise noted. All visual content is copyright to its respectful owners. Information on this site may contain errors or inaccuracies too - we do not make warranty as to the correctness or reliability of the site's content. If you own rights to any of the images, and do not wish them to appear on this site, please leave a private message and it will deleted immediately.

By clicking on " LOGIN " below:
- You acknowledge to have fully read the Term of Service while you registering of this FORUM;
- You commit yourself to respect unreservedly these current rules;
- You grant the moderators of this forum the right to delete, move or edit any discussion subject at any moment.


Please visit http://datanetops.blogspot.com for more info.





 
HomeHome  FAQFAQ  PortalPortal   BLOG  RegisterRegister  Log inLog in  
Never provide your password to anyone, even if this person claims to be a forum moderator or administrator. For more information about this forum please read FAQ or visit datanetops.blogspot.com
Search
 
 

Display results as :
 
Rechercher Advanced Search
Latest topics
» Which Technology is Better: GSM or CDMA?
Mon Aug 23, 2010 1:14 pm by Boazdexter

» Cisco Router Simulator Software
Sat Jul 10, 2010 2:46 pm by Enforcer

» Ceragon Software
Sat Jul 10, 2010 2:42 pm by Enforcer

» Chariot v4.3.1212 for Windows (c) NetiQ
Sat Jul 10, 2010 2:36 pm by Enforcer

» IP Security Software
Sat Jul 10, 2010 1:01 pm by Enforcer

» Linux Application software
Wed Mar 31, 2010 11:19 am by Enforcer


Top posters
Enforcer
 
Congressman
 
jemscaburn
 
Boazdexter
 

Share | 
 

 Installation Guide - CISCO Router WAN (HDLC), NAT and Transparent Proxy

View previous topic View next topic Go down 
AuthorMessage
Enforcer
Private
Private


Posts : 28
Join date : 2010-01-31
Age : 37

PostSubject: Installation Guide - CISCO Router WAN (HDLC), NAT and Transparent Proxy   Thu Feb 04, 2010 4:43 pm


CISCO Router WAN (HDLC), NAT and Transparent Proxy Example


[You must be registered and logged in to see this image.]


+++++++++++++++++++++++++++++++++++++++++



XXXX#show running-config
Building configuration...

Current configuration : 3424 bytes
!
version 12.1
service nagle
no service pad
service timestamps debug datetime msec localtime show-timezone
service timestamps log uptime
service password-encryption
!
hostname XXXX
!
boot system flash
logging buffered 8192 debugging
aaa new-model
aaa authentication login default local enable
enable secret 5 12345678901234567890
!
username user1 password 7 12345678901234567890
username user2 password 7 12345678901234567890
username user3 password 7 12345678901234567890
!
clock timezone PH 8
ip subnet-zero
no ip source-route
ip domain-list test.com
ip domain-name test.com
ip name-server 202.0.0.1
ip name-server 202.0.0.2
!
interface Ethernet0/0
description Private LAN
ip address 192.168.0.4 255.255.255.0
no ip redirects
no ip proxy-arp
ip accounting access-violations
ip nat inside
no ip mroute-cache
ip policy route-map proxy-redirect
no cdp enable
!
interface Serial0/0
description 64K HDLC link to ISP
bandwidth 64
ip unnumbered Ethernet0/1
ip access-group 100 in
ip access-group 101 out
no ip redirects
no ip proxy-arp
ip accounting access-violations
ip nat outside
no ip mroute-cache
down-when-looped
no cdp enable
!
interface Ethernet0/1
description External (DMZ) LAN
ip address 202.0.0.14 255.255.255.240
no ip redirects
no ip proxy-arp
ip accounting access-violations
no ip mroute-cache
no cdp enable
!
ip nat inside source list 1 interface Ethernet0/1 overload
ip classless
ip route 0.0.0.0 0.0.0.0 Serial0/0
no ip http server
!
logging facility local1
logging source-interface Ethernet0/1
logging 202.0.0.1
access-list 1 permit 192.168.0.0 0.0.0.255
access-list 100 permit icmp any 202.0.0.0 0.0.0.15
access-list 100 permit tcp any 202.0.0.0 0.0.0.15 established
access-list 100 permit tcp any 202.0.0.0 0.0.0.15 gt 1023
access-list 100 permit udp any 202.0.0.0 0.0.0.15 gt 1023
access-list 100 permit tcp any 202.0.0.1 0.0.0.0 eq domain
access-list 100 permit udp any 202.0.0.1 0.0.0.0 eq domain
access-list 100 permit tcp any 202.0.0.2 0.0.0.0 eq domain
access-list 100 permit udp any 202.0.0.2 0.0.0.0 eq domain
access-list 100 permit tcp any 202.0.0.1 0.0.0.0 eq smtp
access-list 100 permit tcp any 202.0.0.1 0.0.0.0 eq pop3
access-list 100 permit tcp any 202.0.0.2 0.0.0.0 eq www
access-list 100 deny tcp any 202.0.0.0 0.0.0.15 eq 2049 log
access-list 100 deny udp any 202.0.0.0 0.0.0.15 eq 2049 log
access-list 100 deny tcp any 202.0.0.0 0.0.0.15 eq 6000 log
access-list 100 deny ip any any log
access-list 101 permit ip 202.0.0.0 0.0.0.15 any
access-list 101 deny ip any any log
access-list 102 permit ip 202.0.0.0 0.0.0.15 any
access-list 102 permit ip 192.168.0.0 0.0.0.255 any
access-list 102 deny ip any any log
access-list 110 deny tcp any any neq www
access-list 110 deny tcp host 202.0.0.1 any
access-list 110 permit tcp any any
no cdp run
route-map proxy-redirect permit 10
match ip address 110
set ip next-hop 202.0.0.1
!
snmp-server community public RO
!
line con 0
line aux 0
line vty 0 4
access-class 102 in
exec-timeout 0 0
password 7 11111C0A19
transport input telnet
transport output none
!
ntp server 202.144.158.193
end



On a Linux system with IPTables, and the proxy software installed locally you would simply need:

iptables -A PREROUTING -s 192.168.0.0/28 -p tcp -m tcp \
--dport 80 -j REDIRECT --to-ports 8080

Or if the proxy is on a different system:

iptables -t nat -A PREROUTING -p tcp --dport 80 \
-i eth0 -j DNAT --to 202.0.0.2:8080


If you are using squid, you should give these in /etc/squid/squid.conf

httpd_accel_host virtual
httpd_accel_port 80
httpd_accel_with_proxy on
httpd_accel_uses_host_header on

Or if you are using Delegate, nothing to change


[You must be registered and logged in to see this image.]
Back to top Go down
http://ajpuno.50webs.com
 
Installation Guide - CISCO Router WAN (HDLC), NAT and Transparent Proxy
View previous topic View next topic Back to top 
Page 1 of 1
 Similar topics
-
» Selenium installation guide for java.
» Selenium installation problems
» HyperMedia 72Channels nd Cisco Router for sale
» Instructions to setup selenium 2.
» Easier method to reduce your personalised Windows 7/8/8.1 installation (without Sysprep)

Permissions in this forum:You cannot reply to topics in this forum
Pinnacle - Hitting the highest Point :: Community Update :: Technical Help and Troubleshooting :: IP and Data Services-
Jump to:  
Forumotion.com | © phpBB | Free forum support | Contact | Report an abuse | Free forum